sábado, marzo 10, 2007

Error al actualizar mkinitrd en Fedora Core

Si en Fedora (Core 6) al intentar actualizar los paquetes (con Package Updater) recibes un mensajes de error que te indica que no puedes proceder con la actualización del "mkinitrd":

[('file /sbin/mkinitrd from install of mkinitrd-5.1.19.0.2-1 conflicts with file from package mkinitrd-5.1.19-1', (7, '/sbin/mkinitrd', 0L))]

puedes realizar los siguientes pasos para resolverlo:

Eliminar el paquete mkinitrd-5.1.19.0.2-1 _únicamente_ de la base de datos rpmdb:

$ rpm -e --justdb --nodeps mkinitrd-5.1.19.0.2-1

(no te preoucupes que mkinitrd aún se encuentra en tu sistema y no hay riesgo de que Fedora se vuelva inestable)

luego descargas el paquete mkinitrd y lo instalas usando yum desde la consola:

$ yum install mkinitrd



Para obtener ayuda sobre Fedora Core te recomiendo suscribirte al foro fedora-ve: "Usuarios de Fedora en Venezuela. También conversamos acerca de RedHat y sus clones como Whitebox, CentOS y afines."

Gracias a Wilmer por darme la solución en el foro.

1 comentario:

ж Ĩĝŋϊ§ ж dijo...

Se agradece el aportazo, como dato si no conoces la version de mkinitrd instalada
solo con
rpm -e --justdb --nodeps mkinitrd
igual se elimina.


yum -y install mkinitrd

la instalacion y listo

Kill process in one console command line

example:   $ sleep 3600 & [ 1 ] 2225 $ sleep 3600 & [ 2 ] 2226 $ sleep 3600 & [ 3 ] 2227 $ sleep 3600 & ...